Smash not "sticking"

Discussion on running your own board and editing MajorMUD.
Post Reply
iofhua
Posts: 68
Joined: Wed Oct 09, 2013 6:09 pm

Smash not "sticking"

Post by iofhua » Mon Dec 30, 2019 7:42 pm

I added a custom class and edited the smash quest to give it to my new class.

I can complete the quest as my new class and then sys goto newhaven and smash a rat or slime or whatever. But about 1 or 2 minutes later it says I don't know the first thing about smashing. So it's giving me the ability, but then it doesn't stick around.

I've seen similar behaviour before when I edited in a custom room but didn't compile the update. I was able to go into the room but a few minutes later MajorMUD decided that room didn't exist anymore and I couldn't get back in.

Is there anything else I should do for the ability quests beyond adding class checks to the relevant text blocks? I thought maybe adding the smash ability with a value of 0 to my class might help (the quest gives the ability with a value of 1) but that just made the class start out with smash at level 1. The other classes don't even have an entry for smash or meditate to it makes me think the ability quests are intended to add a whole new entry for the ability rather than just change a value.

I'm not sure what to do. Has anyone else added a custom class and run into this issue?


User avatar
BearFather
Posts: 539
Joined: Sun Feb 09, 2014 6:27 pm
Location: Portland, OR
Contact:

Re: Smash not "sticking"

Post by BearFather » Mon Dec 30, 2019 9:51 pm

The only thing I can think of is did you extend the class limit in the DLL? Cause you get weird behavior with custom classes if you don't.


iofhua
Posts: 68
Joined: Wed Oct 09, 2013 6:09 pm

Re: Smash not "sticking"

Post by iofhua » Tue Dec 31, 2019 8:01 am

Nope I didn't know I had to edit a DLL. Would you happen to know the name of the file?

Is it something I can do in notepad? I also have HxD hex editor if I need to use that.


User avatar
BearFather
Posts: 539
Joined: Sun Feb 09, 2014 6:27 pm
Location: Portland, OR
Contact:

Re: Smash not "sticking"

Post by BearFather » Tue Dec 31, 2019 10:13 am

https://kyau.net/wiki/MajorMUD:Documentation

Thats the page for you, and the dll I think is wccmmud.dll, but I could be wrong been a bit since I dove into it.


iofhua
Posts: 68
Joined: Wed Oct 09, 2013 6:09 pm

Re: Smash not "sticking"

Post by iofhua » Sun Jan 05, 2020 3:23 pm

I verified it is wccmmud.dll that has those hex entries. I'm making the edits now. Reminds me of when I used game genie codes back in the day.

Whoever manages that wiki should put the file name under the "Hex Edits" part. That the changes have to be made to wccmmud.dll in the WGSERV folder.

Hopefully this fixes my issues. I'll test it out once I'm done.


iofhua
Posts: 68
Joined: Wed Oct 09, 2013 6:09 pm

Re: Smash not "sticking"

Post by iofhua » Sun Jan 05, 2020 4:29 pm

Smash seems to work okay now. I think that fixed it.

Thanks!


User avatar
BearFather
Posts: 539
Joined: Sun Feb 09, 2014 6:27 pm
Location: Portland, OR
Contact:

Re: Smash not "sticking"

Post by BearFather » Mon Jan 06, 2020 10:17 am

Sweet, glad my knowledge is useful. Yeah I also noticed he doesn't mention the dll name. I guess since most people back in the day just know its wccmmud.dll. Might be an over site.


Post Reply