FIRE IN THE HULL!!! -*Problem*-

General MajorMUD Discussion
Julian
Posts: 33
Joined: Sun Oct 28, 2018 8:43 am

FIRE IN THE HULL!!! -*Problem*-

Post by Julian » Thu May 23, 2019 9:04 am

Hello,

Woke up this morning, and realized that something is wrong with my server. Problem.

It keeps burping every hour at x:54 (am/pm) ; meaning: Every hour, everyone disconnects and reconnects.
The server does not shut down. It's purely a network issue. It bumps everyone off, then back on again.
This has been happening for 2 days.

I don't know if it is:
1. My PC Network Connection
2. Router
3. Cable Modem
4. ISP
5. ???

The WG server is up and running. Says it has been since the 3am cleanup.

Hope someone can help me..

Julian


User avatar
BearFather
Posts: 479
Joined: Sun Feb 09, 2014 6:27 pm
Location: Portland, OR
Contact:

Re: FIRE IN THE HULL!!! -*Problem*-

Post by BearFather » Thu May 23, 2019 10:05 am

Something in your network is dyeing or you are being attacked. I had this issue recently and it was every 6 hrs on the dot my network would drop, run like shit for 15 mine and clear up. I thought it was an attack, but it was a bad jack that was picking up interference. And some automated thing was triggering the noise, replaced my frontroom jack and everything was good.

Call your ISP and they can come out and tell you exactly what it is, if he's a good tech.


Julian
Posts: 33
Joined: Sun Oct 28, 2018 8:43 am

Re: FIRE IN THE HULL!!! -*Problem*-

Post by Julian » Fri May 24, 2019 6:28 pm

Ok, I did a network reset on the PC, and reset the cable modem and "ROUTER!!!" The router was disconnecting the computer from the LAN, the internet was not being affected. All 3 reset, and the problem went away.


Now, I have someone attacking my board where we would crash with a error 14.

I'm sure this is an attack.. the error takes the board down and forces it to reboot after 30 seconds or so or 5 minutes. I can't remember now. Or you can press OK and it'll just come reboot now.

What is an error 14 and how is this done?
Anyone know?


Julian


User avatar
BearFather
Posts: 479
Joined: Sun Feb 09, 2014 6:27 pm
Location: Portland, OR
Contact:

Re: FIRE IN THE HULL!!! -*Problem*-

Post by BearFather » Fri May 24, 2019 10:30 pm

What goes along with that error 14? It could be a bad message or pointing to bad record. If you running stock check the bards cloak it can crash a board, if it's edited then it could be a bad edit. There is a file in the wgserv folder that will contain the error, I want to say its galerror.out, but search for *.out in the folder you will see it.


Julian
Posts: 33
Joined: Sun Oct 28, 2018 8:43 am

Re: FIRE IN THE HULL!!! -*Problem*-

Post by Julian » Fri May 24, 2019 10:47 pm

Is it ok if I delete the .out files that are there? They are huge.. I don't think I can find it unless it happens again.

And the files that I did see: They are not in any kind of order..


User avatar
BearFather
Posts: 479
Joined: Sun Feb 09, 2014 6:27 pm
Location: Portland, OR
Contact:

Re: FIRE IN THE HULL!!! -*Problem*-

Post by BearFather » Sat May 25, 2019 12:11 pm

The error will either be at the top or the bottom of the file....and if they are huge you might have a serious issue.


Julian
Posts: 33
Joined: Sun Oct 28, 2018 8:43 am

Re: FIRE IN THE HULL!!! -*Problem*-

Post by Julian » Thu May 30, 2019 10:10 am

Ok, so, I don't know. I was probably hacked.

This is what I'm doing..

I'm resetting. But not resetting the game.


So, this is,
"How to make a fresh install of majormud but keep the old databases." So I'm keeping the game as is, no changes, everything stays the same, the whole realm, all I do is update the new databases and other files to the old level/experience; so it's original, installer version, files: stable build, stock, all fresh files. Just change the experience and level in nightmare for each user. New files, old data, no problem.


You can do a fresh install and then just put the level/or experience for a player from a backup file or type it in yourself in NIGHTMARE.

You can also, copy and add or leave blank the items, spells, etc from the old databases.


What I did:

I use nightmare to export all databases to a separate folder.
Then,
Basically, I do a fresh install of wg server and majormud.
That's it.

Ok, ok, more geeky:
More detail:

All I do, after I have a fresh install, and fresh files is import the items, rooms, messages, and users from that old folder/database files. It's only text data. And Save.

Boom.. problem is solved. Everything is working as it should be.

If you are using different versions of BTRIEVE or have a more complicated non-stock version/install for majormud please see the "HOW-TO's" located in other areas on this site.

This is just a general, very simple, example, of what I do and did after having network problems on my server PC.


Good Luck! & Enjoy!
-Julian


User avatar
BearFather
Posts: 479
Joined: Sun Feb 09, 2014 6:27 pm
Location: Portland, OR
Contact:

Re: FIRE IN THE HULL!!! -*Problem*-

Post by BearFather » Thu May 30, 2019 9:47 pm

That sounds like a lot of work, do you take nightly backups? You should, if you do you can take the dats from that and leave the user file, and a few others like gangs and replace and should cure your issue.

But I would find the real issue that's causing the issue.


Julian
Posts: 33
Joined: Sun Oct 28, 2018 8:43 am

Re: FIRE IN THE HULL!!! -*Problem*-

Post by Julian » Thu Jun 06, 2019 6:15 pm

Bearfather!

Hello!


Umm, actually, it is an attack..

The bbs is up until someone attacks my network. Then it keeps resetting every hour until I reset my network again.

I've had a bbs for years in 2003-2009, maybe more. I never had a network breakdown like now. I don't think it is an issue with windows 10. I think someone is manually attacking. I have URLs coming in that I have banned in the past that don't log in, just check the ports and go. People that come in from the other side of the planet, like china, and such.

-Julian


Julian
Posts: 33
Joined: Sun Oct 28, 2018 8:43 am

Re: FIRE IN THE HULL!!! -*Problem*-

Post by Julian » Thu Jun 06, 2019 6:19 pm

BearFather wrote:
Thu May 30, 2019 9:47 pm
That sounds like a lot of work, do you take nightly backups? You should, if you do you can take the dats from that and leave the user file, and a few others like gangs and replace and should cure your issue.

But I would find the real issue that's causing the issue.
That is a lot of work, there are easier things to do like, simply not touch the dat files, etc. Install basic mdf, etc. to overwrite current files in c:\wgserv directory.

I do take nightly backups, that is not an issue at all.

The issue however persists, that we are getting bumped by the network every hour once someone executes some code somewhere at my cable modem/router level.

If I had a different IP, it may be cured, but I don't think they care about the IP since I have a domain name, regardless of my IP, mbbs1.ddns.net.


-Julian


Post Reply